Whitelabel app issues for some customers

Incident Report for NatwestBoxed

Resolved

We have now resolved the root cause and service has been restored.
Posted Mar 08, 2026 - 18:35 UTC

Update

We are continuing to investigate the issue.
Posted Mar 08, 2026 - 18:11 UTC

Investigating

We’re currently experiencing elevated errors rates in the Whitelabel app
Posted Mar 08, 2026 - 16:30 UTC
This incident affected: Customer Onboarding, Inbound payments, Outbound payments, and Customer Login, View Balance & Transactions.